It is currently 04 Aug 2020, 05:36

• Featuring Members' Works (Image Attachments) •
1: member
2: member
3: member
4: member
5: member

GIMP/GL:  Tutorials | Tips | 🡆 Questions | Interests | Script Requests
Recommendations:  Index | Top 10
Resources:  Python-Fu Plug-ins | Scheme-Fu Scripts | GIMP
Python:  Lessons | Questions | Exercises
The Arts:  GIMPed | GIMPed Photos | Other | Contests | Public Domain Images | Isolated Images | Blender
Inkscape
Social:  Say Hello | Anything Goes | Shares | FCSP

Can't reset default colors on start

GIMP or GIMP LEARN forum related Questions
RJKD
Tutorial Creator

Can't reset default colors on start

Post#1 by RJKD » 22 Jun 2017, 10:53


Every time i start my Gimp it opens with white - background color and brown - foreground color. I read on Gimp Chat that someone else had this problem and they resolved it by Preferences > tool options > reset tool options to default value. I've done this several times to no avail.
Can anyone please suggest a way to fix this?
It's not such a big deal, however I'm now curious as to the answer.
Thankyou in advance.
0

rich2005
GIMP Guru

Post#2 by rich2005 » 22 Jun 2017, 13:11


Strange, that should have worked.

What you can try is, set the FG / BG the way you want ( and any other tools, while you are there )

Click on 'Save tool Options Now' (if Save tool options on exit is unticked Gimp will start as set up each time.)

Image
0

RJKD
Tutorial Creator

Post#3 by RJKD » 22 Jun 2017, 14:31


Thankyou for you reply rich2005,tried that a few times to no avail, snookered on this one?
0

rich2005
GIMP Guru

Post#4 by rich2005 » 22 Jun 2017, 16:09


Desperation measures called for ;)

go into your Gimp profile and delete the file contextrc, that is the equivalent of reseting the tool options.

Image

Have you considered getting Gimp set up the way you want it, then maybe saving the Gimp profile to a memory stick, that way easily restored in case of emergencies.
0

RJKD
Tutorial Creator

Post#5 by RJKD » 22 Jun 2017, 18:56


Thankyou for the guidance, I will use a memory stick. I did delete as you recommended, re-started, (black still brown, so changed back to black), saved tool options. Re-started Gimp and black still brown. In fact, I tried a few times to no avail. Oh well, never mind, I'm sure a solution will emerge.
0

Wallace
Global Moderator

Post#6 by Wallace » 25 Jun 2017, 03:04


RJKD wrote:
22 Jun 2017, 18:56
Thankyou for the guidance, I will use a memory stick. I did delete as you recommended, re-started, (black still brown, so changed back to black), saved tool options. Re-started Gimp and black still brown. In fact, I tried a few times to no avail. Oh well, never mind, I'm sure a solution will emerge.
As last-ditch effort, you could create a new User Profile.
To see if this does the trick.
Doing this will basically create a fresh User Profile.
With everything that comes with a new, just installed Gimp.
It will create a clean User Profile, void of any user added resources.

If this doesn't work,
you can delete the newly created profile and revert back to using the old one.

If this does work,
you'll need to find out what it is within the old profile, that's actually causing the issue.

Do you know how to do this,
without losing your old User Profile?
Image
0

RJKD
Tutorial Creator

Post#7 by RJKD » 23 Jul 2017, 12:50


Oh well, tried every which way, I'm not proficient enough to be able to find a needle in a haystack in my old user profile. So, I'm living with it, on the scale of things, it's probably the least of my problems. Thankyou to those who suggested options, even Conbagui, who inadvertently reminded me I'm due for an eyesight test.
0

rich2005
GIMP Guru

Post#8 by rich2005 » 23 Jul 2017, 15:35


Just out of interest :) If you bring up the Change Foreground Colour dialogue, what colour is showing as Current? example:

Image

Might give someone a clue for a fix.
0

RJKD
Tutorial Creator

Post#9 by RJKD » 23 Jul 2017, 16:12


Here's the color on start-up rich...
Start_up_forground_color.png
Start_up_forground_color.png (30.08 KiB) Viewed 2238 times
0

rich2005
GIMP Guru

Post#10 by rich2005 » 23 Jul 2017, 17:00


That is a nice *not black* ;)

What happens if you set all the sliders to the left, that is zero them, to give black

Ok that, which should give black as the foreground colour.

Then do your, Edit -> Preferences -> Tool Options -> Save Tool Options Now

OK that, then restart Gimp - any difference?
0


GIMP/GL:  Tutorials | Tips | 🡆 Questions | Interests | Script Requests
Recommendations:  Index | Top 10
Resources:  Python-Fu Plug-ins | Scheme-Fu Scripts | GIMP
Python:  Lessons | Questions | Exercises
The Arts:  GIMPed | GIMPed Photos | Other | Contests | Public Domain Images | Isolated Images | Blender
Inkscape
Social:  Say Hello | Anything Goes | Shares | FCSP

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 6 guests